Back to overview
Downtime
Console UI is broken
Mar 4, 2026 at 2:29pm UTC
Affected services
Console
Resolved
Mar 4, 2026 at 3:27pm UTC
We rolled back the recent changes and are investigating the cause of the problem.
Affected services
Created
Mar 4, 2026 at 2:29pm UTC
Our team investigating the problem
Affected services